Problem mit Umlauten in CHM-Dateien

Altes Forum, Mittwoch, 14.04.2004, 17:31 (vor 5207 Tagen)

Gast

Registriert: -
Beiträge: -
12.11.2002 - 19:10: Problem mit Umlauten in CHM-Dateien |

Hallo, Hat jemand Informationen oder Patches zu dem Problem mit deutschen Umlauten in CHM-Dateien> Z. B. wird bei einem Wort mit A-Umlaut in Verbindung mit einem Platzhalter entweder garnichts gefunden oder nur die entsprechenden Suchbegriffe mit dem Buchstaben A. Vielen Dank im Voraus. Reinhard


Thomas Schulz (M+)

Registriert: 27.03.2004
Beiträge: 137
13.11.2002 - 16:26: Re: Problem mit Umlauten in CHM-Dateien |

Hallo Reinhard, kann das Problem leider nicht reproduzieren. Tritt der Fehler auch auf unterschiedlichen Rechnern auf> Trotzdem hier schon mal einige Ideen: Schau doch mal in den "Project options" deiner Projektdatei, ob die Sprache auf "Deutsch" steht. Sinnvoll ist auch die Zeichensatzangabe im Kopfbereich der *.htm Dateien. z.B.: <meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1"> Hilft das alles nichts, kann unter Umständen das Shareware Tool FAR von Rob Chandler helfen. Es ist, soweit ich weis, in der Lage ohne Probleme mit Umlauten umzugehen. http://www.helpware.net/FAR/in dex.html Ich hoffe du kannst hiermit wenigstens etwas anfangen. Gruß Thomas

Gast

Registriert: -
Beiträge: -
13.11.2002 - 21:53: Re: Problem mit Umlauten in CHM-Dateien |

Hallo Thomas, ich habe sowohl den deutschen Zeichensatz im Kopfbereich der HTML-Datei als auch die deutsche Sprache in der Projektdatei angegeben. Auch habe ich versucht in den HTML-Dateien die Kodierung für Umlaute (ä usw.) durch normale Umlaute zu ersetzen, das hat aber auch nichts gebracht. Ich (und Andere) habe(n) die CHM-Datei auf verschiedenen Rechnern ausprobiert - überall das gleiche Problem. FAR von Rob Chandler werde ich nun auch noch ausprobieren, glaube aber nicht daß es was bringt, denn die originalen CHM-Hilfedateien von Windows weisen dasselbe Problem auf. Solange man Worte ohne Platzhalter sucht ist alles in Ordnung. Doch sobald man ein Wort wie z.B. "wäre*" sucht, werden nur die Worte mit "a" markiert - also z.B. "Ware", "waren", "waret", "warest" usw.. MfG und Dank Reinhard

Gast

Registriert: -
Beiträge: -
16.11.2002 - 21:59: Re: Problem mit Umlauten in CHM-Dateien |

Hallo Reinhard, bei mir tritt der gleiche Fehler auf. Ich arbeite auch mit FAR, der Fehler tritt leider trotzdem auf. Es gibt scheinbar noch einen weiteren Umlaut-Bug und zwar wenn man direkt nach einem Umlaut sucht z.B. "wäre" und sucht "w>re", wird das Thema zwar gefunden, aber die Suchbegriffshervorhebung deaktiviert. Wird es überhaupt noch patches geben für die Versin 1.x, oder wird zukünftig von Microsoft nur noch 2.x unterstützt> Gruß, Bernd

Gast

Registriert: -
Beiträge: -
30.11.2002 - 20:46: Re: Problem mit Umlauten in CHM-Dateien |

Hallo Reinhard Weil HTML Help in Windows und lokal läuft und somit viel mehr möglich ist als im Internet (es gibt ja keine www Adressen mit Umlauten und Sonderzeichen), bin ich auch der Versuchung erlegen und in die Falle mit den Sonderzeichen getappt. Seither bewege ich mich wieder "browsermässig", als wärs eine Page im Internet. Unix kompatibel, ohne Umlaute und mit Underscore. Bis auf Kompilationsfehlermeldung bei # Anker - Aufrufen klappts bestens. Liebe Grüsse Robin

powered by my little forum