Forum zur Thematik Windows Hilfen und Hilfesysteme

Bilder einfügen aus Verzeichnis übergeordnetem Verzeichnis

Marco @, Montag, 17. Januar 2005, 18:22 (vor 4843 Tagen)

Hallo,

ich versuche Bilder in ein CHM einzufügen, die oberhalb meiner HTML-Seiten liegen (also sowas <img src="../images/dot.gif">).

Ich habe durch querlesen schon herausbekommen, dass sowas schlecht bzw. gar nicht funktioniert. Es ist aber aus verschiedenen Gründen unbedingt notwendig, dass ich das irgendwie zum laufen kriege.

Frage: Gibt es einen anderen Workaround als diesen:
"Dieses Problem tritt gehäuft bei Computern mit dem Betriebssystem Windows 2000 und installiertem SP4 auf. Bei der Installation des SP4 werden die HTML Help Komponenten mit einem falschen Registry Schlüssel registriert. Um den Fehler zu beheben muss die Datei hhctrl.ocx deregistriert und wieder neu registriert werden. Über Start | Ausführen folgendes eingeben und bestätigen:
regsvr32 /u hhctrl.ocx
danach
regsvr32 hhctrl.ocx
Die jeweils erscheinenden Mitteilungen bestätigen."

Ich habe genau dieses System (Win2000/SP4), aber nach Durchführen der Schritte, konnte ich gar keine CHMs mehr erzeugen (HCC5010: compilation error). Ich musste das SP nochmal neu drüberinstallieren, dass es wieder funktioniert.

Bringt es was das nochmal zu versuchen oder gibt es bereits eine andere Lösung>


MfG
Marco

Bilder einfügen aus Verzeichnis übergeordnetem Verzeichnis

killernase, Montag, 17. Januar 2005, 18:24 (vor 4843 Tagen) @ Marco

Sorry, da hab' ich wohl das Subject verbockt :-(

MfG
Marco

Bilder einfügen aus Verzeichnis übergeordnetem Verzeichnis

Thomas Schulz ⌂ @, Castrop-Rauxel, Montag, 17. Januar 2005, 21:22 (vor 4843 Tagen) @ Marco

Hallo Marco,

das eine hat mit dem anderen nichts zu tun.
Die Problematik, dass sich Bilder in Verzeichnissen, die oberhalb des Projektverzeichnisses liegen nicht kompilieren lassen, ist meines Wissens nach nicht zu korrigieren.
Dies hat nichts mit der Vorgehensweise der Neuregistrierung der Help Komponenten zu tun. Hier stellt sich die Problematik fehlerhaft registrierter Komponenten, die Fehler bei der Ansicht von Hilfen verursachen, nicht jedoch bei deren Erstellung.

Sofern du deine Grafiken z.B. in einem Ordner c:ProjektImages und deine HTML Seiten in einem Ordner c:ProjektHtml liegen hast, dürftest du keine Probleme haben.
Diese treten eigentlich erst auf, wenn einer der beiden Ordner über deinem Projektordner liegt also z.B. c:Images.

--
Viele Grüße
Thomas Schulz (Administrator)
______________
[image]

powered by my little forum