CHM-Datei nach Aufruf aus dem Programm immer vorne

m.s, Sonntag, 09.01.2005, 12:29 (vor 4939 Tagen)

Hallo zusammen,

wie bekomme ich es hin, dass man bei geöffneter Hilfe im Programm trotzdem weiterarbeiten kann>
Momentan wird die Hilfe geöffnet, blockiert aber die Anwendung. Ich kann die Hilfe zwar minimieren, aber auch dann ist das Programm blockiert.

Grüße
Micha

CHM-Datei nach Aufruf aus dem Programm immer vorne

Thomas Schulz ⌂ @, Castrop-Rauxel, Sonntag, 09.01.2005, 15:46 (vor 4939 Tagen) @ m.s

Hallo Micha,

dieses Verhalten kann an Einstellungen liegen, die das Hilfefenster immer im Vordergrund halten.
Gehe im HTML Help Workshop über Add/Modify window definitions in das Register Extendes Styles und deaktiviere dort die Eigenschaft Topmost.
Ein weiterer Grund für derartiges Verhalten kann die Art und Weise sein, wie du die Hilfe aus deinem Programm heraus aufrufst. Fall es der obere Workaround nicht war, beschreibe bitte wie du den Aufruf der Hilfe durchführst.

--
Viele Grüße
Thomas Schulz (Administrator)
______________
[image]

CHM-Datei nach Aufruf aus dem Programm immer vorne

Ulrich Kulle ⌂, Sonntag, 09.01.2005, 19:46 (vor 4939 Tagen) @ m.s

Hallo Micha,

» wie bekomme ich es hin, dass man bei geöffneter Hilfe im Programm trotzdem
» weiterarbeiten kann>
» Momentan wird die Hilfe geöffnet, blockiert aber die Anwendung. Ich kann
» die Hilfe zwar minimieren, aber auch dann ist das Programm blockiert.

in Ergänzung zu den Hinweisen von Thomas:

Falls du mit Visual Studio.net arbeitest scheint es einen weiteren Fehler zu geben, weil das Anwendungsfesnter trotz Änderung der Eigenschaft "TopMost" nicht vor das Hilfefenster zu bekommen ist.

Du kannst den Effekt am probieren, indem du nach Download des Beispielprojektes von folgender URL die EXE im Verzeichnis /bin startest. Dies setzt natürlich Framework 1.1 voraus.

http://www.help-info.de/de/Visual_Basic_net/vbnet.htm

Starte das Hilfefenster aus dem Menü des Programms, zieh das Fenster etwas über das Anwendungsfenster und versuche die Fenster umzuschalten. Bei API funktioniert alles wie erwartet.

Bisher habe ich hier keine Lösung. Vielleicht findet jemand eine Lösung!

--
Mit besten Grüßen
Ulrich Kulle
Microsoft Help MVP (2007-2009)
************************
http://www.help-info.de
Unterstützen Sie Help-Info.de durch eine PayPal Spende!
https://www.paypal.com

powered by my little forum